ZENONIA S: Rifts In Time

ZENONIA S: Rifts In Time

158,718 1,000,000 - 5,000,000
  • Author:

  • Latest Version:

    3.5.1

  • Publish Date:

ZENONIA S: Rifts In Time v3.5.1 Mod Apk [Unlimited Money, Hight Demage & Attack] - Game Apk Download

The world’s most popular mobile RPG, ZENONIA®, is now online! !

Travel across nine treacherous realms to uncover the mystery behind the portal.
Assist the Celestial Kingdom and expose the horrifying truth.

Chat and play with your friends in real-time! Join a co-op raid party and fend off vicious monsters in Raid mode. Enter PVP matchups to destroy your competition.

[Real-time Action]
Battle monsters, make friends, and punish challengers all from your mobile device.
Explore the world of ZENONIA S: Rifts in Time across the nine realms.
Test your survival skills in the Monster Wave mode.

[Classes]
Choose from your favorite ZENONIA® characters.
Slasher/ Ranger/ Fighter / Magician / Assassin
Awaken your hero and break the limit.

[Customize]
Customize you character with over 300 different pieces of equipment.
Increase the effectiveness of your weapons, armor, and accessories through various enhancements

Put your skills to the test in ZENONIA S: Rifts in Time. Become legendary!

* This game requires the following permissions for optimal gameplay.
- Permission to sync your Address Book and access device status for Friend Invites
[READ_CONTACTS, READ_PHONE_STATE]
- Permission to sync your Google account
[GET_ACCOUNTS]
- Permission to save necessary game data externally
[READ_EXTERNAL_STORAGE, WRITE_EXTERNAL_STORAGE]

** This game is available in English.
** There may be additional costs when trying to obtain certain items.

* GAMEVIL Official Website : https://www.withhive.com
* GAMEVIL Customer Support : https://global.gamevil.com/support/

Terms of Service: http://terms.withhive.com/terms/bridge/gamevil.html
Privacy Policy: http://terms.withhive.com/terms/bridge/gamevil.html

Whats New
1. Stability improved
Video Trailer
  • Category:

    Role Playing

  • Get it on:

  • Requirements:

    2.3 and up